ePubcheck Error: "An error of type 1 has occurred."

9 posts / 0 new
Last post



I get epubcheck error while validation of epub file.

Using :
> Hand Made ePub file
> latest epubcheck-3
> Mac OS

I search the web but not get the answer and also trying(Putting all the resource files in the validate epub template but get the same thing) to solve this error.

i get this error first time and can't get the meaning ---- "An error of type 1 has occurred".

so in my mind a question appear from last three days WHY this message shown??? WHERE THE PROBLEM is??

Please HELP in this issue.


I can't help much, as that's an OS error and I don't run your OS. Could be a Java problem, could be a problem with epubcheck on Macs or could be something else. You might try opening an issue in the epubcheck tracker and see if the developers can tell you anything useful.

Hello Matt,

Thanks for your answer regarding this issue.

I'll open this issue in epubcheck.....

I had the same problem. I don't know if you resolved it, but here is what I found.

I found out that one of my CSS class had "%" (percent sign ) in the name.

Check out your CSS carefully for unusual signs.

That solved it for me.

Good luck

Interesting. Epubcheck only does some basic CSS checking at this point, so it's always a good idea to manually check your style sheets.

today i was get the same error, but editing the identifier in OPF and in ncx meta-uid content resolve it.

In this issue,OPF identifier has value of string/number as a sentence which contain spaces and other special characters so i removed/replaced and resolve it at this time.

That's interesting, since there aren't any special characters in epub identifiers. The value only has to be a non-empty string. The only potentially problematic character for the dtb:uid would be quote characters, depending on which you use in the ncx.

Whitespace before/after the identifier in the content attribute in the ncx can cause validation problems, since it's not trimmed, but that sounds like altogether a different problem.

Could you elaborate on what specific string you had that caused this problem? Using a "sentence" seems like an odd choice for an identifier, but should be valid.

And in case the above is not clear, there aren't any special characters defined by EPUB. XML special characters would cause problems (left angle bracket and unescaped ampersand), but you should get a standard validation error if you used those.

thanks for submitting issue to epubcheck open source project tracker on github... at a minimum it seems like an insufficiently detailed message and there's no documentation about what it means. https://code.google.com/p/epubcheck/wiki/Errors indicates others have had it. but github project is where discussion of fixing that should happen, not here. 

Secondary menu